one.luno.com temporarily unavailable
Incident Report for Luno
Resolved
Our team is working on getting a new and improved website back up soon for a better user experience. Thanks for your patience.
Posted Sep 12, 2022 - 14:24 UTC
Update
This is taking a little longer than expected, we'll be back soon!
Posted Sep 01, 2022 - 11:41 UTC
Update
Maintenance is taking longer than expected, we're taking the time to make one.luno.com a better experience - we'll update everyone once the website is available again.
Thanks for your understanding.
Posted Aug 29, 2022 - 14:34 UTC
Identified
Due to unscheduled maintenance, one.luno.com is currently unavailable to customers. Our team is aware and is busy working with our provider to get the site back up as soon as possible. Updates to follow.
Posted Aug 29, 2022 - 08:59 UTC