Email support ticket delays
Incident Report for Luno
Resolved
Email support ticket creation is now working optimally without interruption. There may be slight delays in receiving responses from our support team as we work through a backlog of tickets. Thank you for your patience while we fixed the issue.
Posted Mar 06, 2023 - 10:53 UTC
Monitoring
The fix has been implemented and we're seeing an improvement in ticket creation. There should be minimal to no errors experienced when customers attempt to make contact with us through the email channel. We will continue to monitor and keep you updated. Thank you for your patience.
Posted Mar 06, 2023 - 09:44 UTC
Identified
We have identified the issue and we are working on a fix. Updates to follow shortly.
Posted Mar 06, 2023 - 09:06 UTC
Investigating
We are currently experiencing delays with receiving support tickets created through our Help Center. Our live chat contact channel is unaffected and is the best alternative means of contact for urgent customer requests. Customers might see some errors when attempting to open their newly created tickets within our app. We are working on fixing the issue as promptly as possible and we apologize for any inconvenience caused.
Posted Mar 06, 2023 - 07:27 UTC