No further issues, thanks for your patienence. We'll continue to monitor.
Posted Nov 24, 2024 - 05:38 UTC
Monitoring
XLM should be available to customers again, if you receive an error when trying to purchase XLM please try again in a few minutes or use the Exchange to place an order.
Posted Nov 23, 2024 - 10:48 UTC
Identified
Some customers may see issues buying XLM on Instant Buy - we're working on a fix. The Exchange remains available as a temporary work around.