Scheduled maintenance for express withdrawals in South Africa
Incident Report for Luno
Resolved
Maintenance has been completed, express withdrawals are being processed as normal.

Thank you.
Posted Jul 08, 2024 - 06:35 UTC
Identified
During this time, express withdrawals with some banks will be impacted and delayed.

Maintenance is between 23:00 SAST on 7 July and 00:30 SAST on 8 July 2024.

Thank you for your understanding
Posted Jul 05, 2024 - 08:55 UTC