Instant EFT via PayU in South Africa
Incident Report for Luno
Resolved
PayU deposits are now being processed successfully.
Posted May 07, 2021 - 10:20 UTC
Investigating
Instant EFT with PayU deposits may fail for some customers. We are working to get this issue resolved. In the meantime, please make use of an alternative deposit method in your Luno wallet.
Posted May 07, 2021 - 04:20 UTC