Delayed ETH sends and receives
Incident Report for Luno
Resolved
This has been resolved and all ETH sends and receives are working as expected.
Posted Feb 08, 2024 - 14:11 UTC
Investigating
We are currently investigating an issue causing delays in ETH sends and receives.

We are working on this as a priority and will update here as soon as possible.
Posted Feb 08, 2024 - 11:51 UTC