Degraded performance
Incident Report for Luno
Resolved
Services have returned to normal across the board, thanks for your patience during this time.
Posted Mar 01, 2023 - 16:26 UTC
Monitoring
Performance has normalised, we're monitoring closely.
Posted Mar 01, 2023 - 16:15 UTC
Investigating
We are currently investigating degraded performance. We are looking into this as a matter of urgency.
Posted Mar 01, 2023 - 15:53 UTC