Delayed Ethereum sends
Incident Report for
Luno
Resolved
There are no further delays with ETH sends.
We apologise for any inconvenience and appreciate your patience.
Posted
Feb
19
,
2025
-
14:05
UTC
Monitoring
A fix has been deployed for this and we are seeing no further issues with Ethereum sends at this time.
We will continue to monitor for any further issues.
Posted
Feb
18
,
2025
-
08:31
UTC
Investigating
We are currently investigating an issue which may be causing customers to experience delays when sending ETH.
We are working on this as a matter of priority and will provide updates as soon as they become available.
Posted
Feb
18
,
2025
-
08:03
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Ethereum sends
via . You'll receive .