Card payments temporarily unavailable in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Feb 24, 2023 - 14:26 UTC
Investigating
Our card payment provider is currently experiencing issues. Please use an alternative payment method in the meantime.
Posted Feb 24, 2023 - 10:05 UTC