Scheduled Maintenance Impacting Verification in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved
Posted Jan 17, 2025 - 06:11 UTC
Identified
Due to scheduled maintenance, our verifications in Indonesia will be delayed.

Maintenance Schedule:
Date: Thursday, January 16, 2025
Time: 22:00 Jakarta Time
Expected Downtime: Approximately 4 hours

Our team will be closely monitoring the situation and will provide updates as the maintenance progresses.
Posted Jan 16, 2025 - 07:08 UTC