Delayed sends in Malaysia
Incident Report for Luno
Resolved
We are continuing to work on a fix.
Posted Oct 24, 2022 - 01:03 UTC
Investigating
We are currently investigating an issue causing delayed sends for some customers, receives remain unaffected.
Posted Oct 23, 2022 - 22:15 UTC