Slow Bank Deposits in Malaysia
Incident Report for Luno
Resolved
Deposit via bank transfer are now being processed as scheduled. Thank you
Posted May 18, 2022 - 03:47 UTC
Investigating
We are aware of a delay with deposits via Bank Transfer and our team is currently investigating it. We hope to have this resolved soon. In the meantime, please make use of FPX, an alternative deposit method in your Luno wallet.
Posted May 10, 2022 - 07:08 UTC