ETH Crypto Sends

Incident Report for Luno

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 19:15 UTC

Identified

We are currently experiencing an issue with ETH sends not processing.

Rest assured, our team is actively working on fixing this as a matter of priority. We sincerely apologise for the inconvenience this causes and appreciate your patience.
Posted Jun 05, 2026 - 17:02 UTC