Delayed Luno Pay payments in South Africa
Incident Report for Luno
Resolved
This incident has been resolved. Payments are now being processed as expected.

We appreciate your patience.
Posted Jan 18, 2025 - 16:46 UTC
Monitoring
Payment delays affecting Luno Pay has been mitigated. The issue with our third-party service provider has been resolved, and payments are being processed as expected.

We continue to monitor the situation closely.
Posted Jan 18, 2025 - 09:53 UTC
Identified
Please be aware that some Luno Pay payments may experience delays. This is due to an issue with one of our third-party service providers. We are actively working with them to resolve the matter and will provide updates as soon as we have more information.

We appreciate your patience and understanding.
Posted Jan 18, 2025 - 07:01 UTC