Delayed Deposits in Nigeria

Incident Report for Luno

Resolved

The issue has been resolved, thank you for your patience.
Posted Mar 08, 2025 - 22:59 UTC

Investigating

We are currently facing issues with delayed deposits, we are investigating the issue
Posted Mar 08, 2025 - 22:40 UTC