Delayed SMS delivery
Incident Report for
Luno
Resolved
Update:
We are no longer seeing any delays with SMS deliveries.
We appreciate your understanding in this matter.
Posted
Dec
25
,
2025
-
17:44
UTC
Identified
We are currently experiencing delays in SMS deliveries for some of our customers.
Our team is aware of the issue and is investigating it urgently.
We appreciate your patience and understanding in this matter.
Posted
Dec
25
,
2025
-
16:20
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed SMS delivery
via . You'll receive .