Delayed Sends and Receives
Incident Report for
Luno
Resolved
The issue has been resolve, we apologise for any inconvenienced caused.
Posted
May
15
,
2025
-
21:58
UTC
Identified
We are currently experiencing an issue where some of our coins are delayed. We are working on resolving the issue
Posted
May
15
,
2025
-
19:11
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Sends and Receives
via . You'll receive .