Delayed crypto sends
Incident Report for Luno
Resolved
The issue regarding delays in crypto sends has been resolved.

We appreciate your patience in this regard.
Posted Jul 26, 2022 - 10:37 UTC
Identified
Some customers may experience delays with some crypto sends.

We are working on this as a matter of priority.
Posted Jul 26, 2022 - 08:51 UTC