Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 06, 2022 - 06:30 UTC
Identified
Withdrawals in Malaysia will not be processed from 30th April to 4th May due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 5th May.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Apr 27, 2022 - 10:36 UTC