Delayed bank withdrawals
Incident Report for Luno
Resolved
This issue has been resolved.

We apologise for any inconvenience this may have caused.
Posted May 09, 2024 - 09:19 UTC
Monitoring
A fix has been implemented and withdrawals are being processed as normal.

We will continue to monitor for any further issues.
Posted May 08, 2024 - 16:05 UTC
Identified
We have identified an issue that may cause some delayed bank withdrawals to some of our customers in South Africa, Australia, and the United Kingdom. We are working on this as a priority.
Posted May 08, 2024 - 14:45 UTC