Delayed withdrawals in Australia
Incident Report for Luno
Resolved
This incident has been resolved.

Thank you for your patience and understanding.
Posted Jun 10, 2022 - 10:26 UTC
Identified
There are temporary delays with withdrawals requested on 10th June 2022, 11:24 AEST onwards. We’re working with our service provider to see this resolved and will provide an update soon.

We will attempt to process the withdrawals once this matter has been resolved. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934

Thank you for your patience.
Posted Jun 10, 2022 - 01:56 UTC