Delayed bank withdrawals and deposits in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 08:47 UTC
Update
Withdrawals in South Africa will not be processed between Friday 2 April 2021 to Monday 5 April 2021 due to the public holidays, unfortunately, banks do not process withdrawals over weekends or public holidays. This will also affect deposits through normal Bank Transfers to our Standard Bank account. Please use our alternative deposit option through PayU instead.

Withdrawals requested after Thursday cut-off time will be processed on Tuesday the 6th of April 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Apr 01, 2021 - 08:13 UTC
Identified
Withdrawals in South Africa will not be processed between Friday 2 April 2021 to Monday 5 April 2021 due to the public holidays, unfortunately, banks do not process withdrawals over weekends or public holidays. This will also affect deposits through normal Bank Transfers to our Standard Bank account. Please use our alternative deposit option through PayU instead.

Withdrawals requested after Thursday cut-off time will be processed on Tuesday the 6th of April 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Mar 31, 2021 - 11:53 UTC