Delayed Account Verification
Incident Report for Luno
Resolved
Account verification times have returned to normal.
Posted May 05, 2023 - 09:21 UTC
Monitoring
A fix has been implemented and account verifications are working as normal, we will continue to monitor for any further issues.
Posted May 05, 2023 - 08:13 UTC
Identified
We have identified an issue resulting in delayed account verification for some users due to some downtime with a third-party provider.

We hope that this will be rectified soon and will provide an update as soon as we can.
Posted May 05, 2023 - 06:50 UTC