Degraded performance
Incident Report for
Luno
Resolved
Performance has been stable and there is no longer any degraded performance affecting our platform.
We apologise for any inconvenience caused.
Posted
Mar
28
,
2024
-
08:22
UTC
Monitoring
Performance has returned to normal. We are continuing to monitor for any further issues.
Posted
Mar
28
,
2024
-
07:42
UTC
Investigating
Customers might experience delays with orders and balances updating.
Our team is aware of the problem and working on a fix. We will update this when the issue has been resolved. We are working on this as a priority.
Posted
Mar
28
,
2024
-
07:36
UTC
×
Subscribe to Incident
Subscribe to updates for
Degraded performance
via . You'll receive .