Delayed price charts for IMX and HBAR against all fiat currencies

Incident Report for Luno

Resolved

The issue has been resolved, thank you for your patience
Posted Mar 08, 2025 - 17:56 UTC

Investigating

There are delayed price charts for IMX and HBAR,we are currently investigating the issue.
Posted Mar 08, 2025 - 14:40 UTC