Delayed account verification in Indonesia
Incident Report for
Luno
Resolved
This issue has now been resolved
Posted
Feb
18
,
2025
-
14:26
UTC
Identified
We are experiencing delays with account verification for customers in Indonesia. We are working with our service provider to rectify the issue.
We apologise for any inconvenience and will provide an update as soon as possible.
Posted
Feb
18
,
2025
-
07:24
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed account verification in Indonesia
via . You'll receive .