Account verification delays in Nigeria
Incident Report for Luno
Resolved
Our third party verification provider has completed maintenance and account verifications are being processed as normal.

Thanks for your patience.
Posted Feb 02, 2021 - 17:23 UTC
Identified
Customers verifying their level 1 account in Nigeria using their NIN number may experience some delays due to our third party verification service undergoing maintenance.

Please try to verify your account using your BVN number. Maintenance should be complete by 3 February 2021. Thanks for your patience.
Posted Feb 02, 2021 - 09:58 UTC