Delayed NEAR Staking and Rewards
Incident Report for
Luno
Resolved
This incident has been resolved.
Posted
Aug
19
,
2025
-
14:34
UTC
Investigating
We are currently facing delays in our NEAR staking and rewards payouts. There are delays and our team is working to fix the issue. We apologise for inconvenience caused.
Posted
Aug
19
,
2025
-
07:51
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed NEAR Staking and Rewards
via . You'll receive .