Delayed withdrawals in Kenya

Incident Report for Luno

Update

Our payment provider is currently working on resolving the issue affecting withdrawals in Kenya. We are continuing to work closely with them and monitoring progress.

We will share further updates as soon as more information becomes available. Thank you for your continued patience.
Posted Mar 26, 2026 - 13:38 UTC

Identified

We are currently experiencing an issue affecting withdrawals for customers in Kenya due to a disruption with one of our payment providers. As a result, some withdrawal requests may fail or not be processed as expected.

Our team is actively working with the provider to resolve this as quickly as possible.

We appreciate your patience and will provide updates as more information becomes available.
Posted Mar 24, 2026 - 14:48 UTC