Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 11:02 UTC
Identified
Withdrawals in Malaysia will not be processed on 7th June 2021 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 8th June 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jun 04, 2021 - 14:29 UTC