Delayed Crypto Sends
Incident Report for
Luno
Resolved
This has been resolved and crypto sends are working as expected.
We appreciate your patience and apologise for the inconvenience caused.
Posted
Jun
11
,
2024
-
10:19
UTC
Monitoring
A fix has been implemented and we are monitoring crypto sends for any anomalies.
Posted
Jun
11
,
2024
-
10:05
UTC
Identified
The issue has been identified and we are working on a fix.
Thanks for your patience.
Posted
Jun
11
,
2024
-
09:51
UTC
Investigating
We are currently investigating an issue causing delayed crypto sends.
We are working on this as a priority and apologise for the inconvenience caused.
Posted
Jun
11
,
2024
-
09:48
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Crypto Sends
via . You'll receive .