Delayed account verification in Nigeria
Incident Report for Luno
Resolved
Account verification has returned to normal and we anticipate all pending and new requests will be processed within the service level.
Posted Jun 27, 2022 - 09:12 UTC
Identified
We are continually processing account verification requests and expect to return to our normal processing times. A Slight delay is still to be expected and we will provide an update as soon as we have made more progress.
Posted Jun 26, 2022 - 17:54 UTC
Investigating
We are experiencing delays with account verification for new customers in Nigeria. Our service provider is currently experiencing an outage.

We apologise for any inconvenience and will provide an update as soon as possible.
Posted Jun 25, 2022 - 18:02 UTC