Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
All delayed withdrawals have been completed and all new withdrawals are now being processed as scheduled.
Posted Sep 13, 2021 - 07:54 UTC
Identified
We're still working with Standard Bank to see these withdrawals processed as soon as possible.
Posted Sep 13, 2021 - 07:17 UTC
Investigating
We have identified an issue with withdrawals to Standard bank accounts being delayed. Withdrawals processed to standard bank accounts before 17:45 today will be affected.
Posted Sep 11, 2021 - 16:27 UTC
This incident affected: Bank deposits and withdrawals (South Africa).