Some customers cannot view Exchange charts
Incident Report for
Luno
Resolved
No further issues are being reported, thanks again for your patience.
Posted
May
06
,
2024
-
11:39
UTC
Monitoring
No further impact, we're monitoring a little longer.
Posted
May
06
,
2024
-
08:24
UTC
Identified
We've identified the issue and working on a fix as a priority.
Posted
May
06
,
2024
-
06:22
UTC
Investigating
Some customers may not be able to view Exchange charts.
We're investigating urgently.
Posted
May
06
,
2024
-
03:36
UTC
×
Subscribe to Incident
Subscribe to updates for
Some customers cannot view Exchange charts
via . You'll receive .