Slow USDC sends
Incident Report for Luno
Resolved
Sends have returned to normal, thanks for your patience.
Posted Jul 08, 2021 - 07:36 UTC
Identified
A small backlog has developed for USDC sends, this is due to a large spike in fees and general congestion on the blockchain. We hope to see this clear soon.

Customers who have sent USDC on/after 6 June 2021 may see their transactions show as processing. There is no need to do anything.
Posted Jul 07, 2021 - 08:12 UTC
This incident affected: Crypto sends and receives (USDC).