Crypto Sends and Receives temporarily Paused - Security update in Nigeria

Incident Report for Luno

Resolved

We've successfully completed the scheduled round of security alignment with our partners, and crypto sends are now fully re-enabled.

Thank you for your patience and continued trust.
Posted Sep 15, 2025 - 08:00 UTC

Identified

We have temporarily paused crypto sends to complete a scheduled round of security alignment with our partners. This is a proactive step to ensure stronger protection and long-term reliability during partner/network changes.

Impact: Outbound on-chain transfers only.
Unaffected: Buy/sell trading, deposits, fiat withdrawals, account access, price alerts.
Customer funds: Held 1:1 under our standard custody controls.

While you can't create or view your receive addresses, rest assured that all your existing addresses are still active and will work as expected.

What to do: No action is required.
Posted Sep 11, 2025 - 23:00 UTC