Delayed withdrawals and deposits in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 11:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2023 - 06:05 UTC
Identified
There may be a temporary delay with processing withdrawals and deposits in Nigeria today 18.03.2023
We’re closely working with the teams to see this resolved soon.
Posted Mar 18, 2023 - 14:59 UTC