Delayed SMS's in Nigeria
Incident Report for
Luno
Resolved
This incident has been resolved.
Posted
Jul
29
,
2025
-
12:44
UTC
Identified
We have identified an issue that may cause some customers to experience delayed SMS delivery in Nigeria.
Unfortunately, this issue is at a network level, but we are working with our 3rd party providers to solve this ASAP.
We appreciate your understanding in this matter.
Posted
Jul
22
,
2025
-
15:15
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed SMS's in Nigeria
via . You'll receive .