The issue causing delayed crypto transactions has been fully resolved. All stuck or pending crypto sends have now been successfully processed, and there are no further delays.
Thank you for your patience and understanding.
Posted Feb 19, 2025 - 14:15 UTC
Monitoring
A fix has been implemented, and crypto sends are now processing successfully. We will continue monitoring for any further issues.
We apologise for any inconvenience and appreciate your patience.
Posted Feb 18, 2025 - 19:45 UTC
Investigating
We are currently investigating an issue that may be causing delayed crypto sends for some customers. The following cryptocurrencies are impacted:
XRP XBT LTC BCH ERC20 tokens
We are treating this issue as a priority and are actively working to resolve it. We will provide an update as soon as we have more information.