Delayed deposits and withdrawals in Australia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Oct 24, 2022 - 02:24 UTC
Identified
Please be advised that our payments partner will be conducting planned maintenance on their platform as per below schedule:

Sunday, 23 October 2022 12:00 a.m. to 7:00 a.m AEDT.

There may be delays in deposit allocation and withdrawal processing during this time. We are truly sorry for the inconvenience.

All services will resume as per usual after the maintenance is complete.

Thanks for your understanding.
Posted Oct 21, 2022 - 06:46 UTC