Delayed crypto sends Singapore
Incident Report for Luno
Resolved
The issue causing delayed crypto sends in Singapore has been resolved.

We apologize for any inconvenience caused and we appreciate your patience in this regard.
Posted Nov 03, 2022 - 07:15 UTC
Investigating
We are currently investigating an issue causing delayed crypto sends for all coins.

We are working on this as a priority.
Posted Nov 02, 2022 - 08:49 UTC