Degraded performance on Exchange
Incident Report for Luno
Resolved
No further errors on the Exchange, we're working on preventative measures to ensure that something similar doesn't happen again.
Thanks for your patience.
Posted May 08, 2020 - 12:17 UTC
Monitoring
A fix has been implemented, we're monitoring for any additional errors.
Posted May 07, 2020 - 14:58 UTC
Identified
We've identified an issue causing degraded performance on the Exchange for both Web and the Android and iOS apps.
Customers using the Web interface may switch back to the old Exchange view for a better performance.

We're working on a fix as a priority.
Posted May 07, 2020 - 13:56 UTC