Delayed transaction and balance updates
Incident Report for
Luno
Resolved
This has been resolved and balance and transaction updates are being reflected as normal.
Posted
Jan
22
,
2024
-
10:15
UTC
Investigating
We are currently investigating an issue causing delayed transaction and balance updates for some customers.
We are working on a fix as a priority and will provide more information once it becomes available.
Apologies for any inconvenience.
Posted
Jan
22
,
2024
-
09:50
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed transaction and balance updates
via . You'll receive .