Log in error for Android users in Malaysia
Incident Report for
Luno
Identified
We are investigating an issue that may affect some customers, causing them to be automatically signed out of their Luno account and unable to sign back in immediately.
Our team is working to identify and resolve this issue.
Updates to follow.
Posted
Aug
26
,
2025
-
07:50
UTC
×
Subscribe to Incident
Subscribe to updates for
Log in error for Android users in Malaysia
via . You'll receive .