Delayed deposits and withdrawals in Nigeria
Incident Report for
Luno
Resolved
Update:
We are no longer seeing any delays with deposits and withdrawals for our Nigerian customers.
We appreciate your patience and understanding with this matter.
Posted
Sep
24
,
2025
-
13:21
UTC
Identified
We have identified an issue currently causing delays with deposits and withdrawals for our Nigerian customers.
Unfortunately, this issue is on our payment providers' side; we are working with them to try to solve this as quickly as possible.
We appreciate your understanding in this matter.
Updates to follow.
Posted
Sep
24
,
2025
-
08:47
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed deposits and withdrawals in Nigeria
via . You'll receive .