Delayed deposits with Xfers in Singapore
Incident Report for Luno
Resolved
This has been resolved and Xfers deposits are working as expected.
Posted Aug 04, 2022 - 12:22 UTC
Update
We are currently investigating an issue causing delayed deposits for some customers when using Xfers.

We are working on this as a priority.
Posted Aug 04, 2022 - 11:35 UTC
Update
We are currently investigating an issue causing delayed deposits for some customers when using Xfers.

We are working on this as a priority.
Posted Aug 04, 2022 - 11:31 UTC
Investigating
We are currently investigating an issue causing delayed deposits for some customers when using Xfers.

We are working on this as a priority.
Posted Aug 04, 2022 - 11:14 UTC
This incident affected: Bank deposits and withdrawals (Indonesia, Malaysia, Singapore).