Degraded performance
Incident Report for
Luno
Resolved
No further impact since our last update, thanks again for your patience.
Posted
Feb
26
,
2025
-
09:23
UTC
Monitoring
We're seeing a better response, our team are monitoring closely.
Posted
Feb
25
,
2025
-
14:47
UTC
Identified
The issue has been identified, our team are working on a fix.
Apologies for any inconvenience caused.
Posted
Feb
25
,
2025
-
13:37
UTC
Investigating
We're seeing an increase in traffic, customers may see some errors or degraded performance.
Updates to follow.
Posted
Feb
25
,
2025
-
13:17
UTC
×
Subscribe to Incident
Subscribe to updates for
Degraded performance
via . You'll receive .