Account verifications in South Africa
Incident Report for Luno
Resolved
Account verification times have been performing as normal as of 11:45 GMT +2 from Sunday 15 August. Thanks again for your patience.
Posted Aug 16, 2021 - 08:04 UTC
Monitoring
A fix has been implemented, the backlog is clearing quickly. We're continuing to monitor and any further potential errors.
Posted Aug 15, 2021 - 09:40 UTC
Update
Unfortunately the issue remains ongoing, customers who signed up at around 17:00 GMT +2 on 14 August 2021 and wanting to verify their account will be unsuccessful. As soon as this is resolved we'll automatically process the backlog.

Apologies for the inconvenience.
Posted Aug 15, 2021 - 07:36 UTC
Identified
Our identity provider had planned maintenance earlier this evening which has resulted in slower than normal account verifications for Level 1 accounts in South Africa. We expected this to clear shortly after maintenance ended however this hasn't been the case.

There is no need to re-submit documents, the backlog will be automatically processed soon.
Posted Aug 14, 2021 - 20:54 UTC