Delayed Bank Deposits in Australia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 01:59 UTC
Identified
Some bank deposits in Australia may experience delays on 22nd September in light of the public holiday.

Affected deposits will resume processing on the 23rd of September.

Customers are encouraged to utilise the PayID instant deposit method during this time. More information can be found here: https://www.luno.com/help/en/articles/11000091992
Posted Sep 21, 2022 - 04:51 UTC