Unable to view tickets created through our help center

Incident Report for Luno

Resolved

The backlog has been cleared and response times have returned to normal.

Thanks again for everyone's patience.
Posted Aug 10, 2022 - 06:58 UTC

Identified

We have identified the issue and a fix has been implemented. We are working through the backlog as fast as we can. You can expect longer than normal response times.

We apologize for any inconvenience caused.
Posted Aug 08, 2022 - 10:55 UTC

Investigating

We have identified an issue where customers are unable to view tickets submitted to our team when following our help center pages. We're investigating urgently.
Posted Aug 08, 2022 - 09:48 UTC